Welcome to Voyager Help

Use the Search field below or select a Category from the list at the left

Invalid License Error

In Voyager versions 1.9.9, 1.9.10, 1.9.11 or 1.9.12, users may not be able to login and will see an INVALID_LICENSE error message, although no changes were made to the program. Both Admin and non-Admin users are affected.

This error occurs when the Maintenance Agreement has expired. Normally when Maintenance has expired, users should still be able to login and use Voyager - the end of Maintenance only means that there will be no updates or customer support available. Voyager instances with newly generated licenses are not affected by this issue. 

NOTE: If Maintenance has expired and a newer version (built after the maintenance expiration date) of Voyager is installed, you will see the INVALID_LICENSE error message. In order to use the new version, you need to purchase an updated Maintenance agreement. In that case, contact Voyager Sales at sales@voyagersearch.com.

Solution

To correct this error, you need to download a patch file and apply it to your Voyager installation.

  1. Back up the files in [install directory]/app/lib before you begin
  2. Shut down Voyager
  3. Download the appropriate patch file for your version of Voyager:

Patch for version 1.9.9

Patch for version 1.9.10

Patch for version 1.9.11

Patch for version 1.9.12

  1. Unzip the downloaded patch file 
  2. Copy all of the unzipped files to [install directory]/app/lib, for example C:\voyager\server_1.9.9\app\lib
  3. Click Yes when prompted to overwrite existing files
  4. Restart Voyager

Contents of the Patch Files

Patch for Version 1.9.9 (VG-6304_1.9.9_patch.zip)

voyager-api-1.9.9-SNAPSHOT.jar
voyager-common-1.9.9-SNAPSHOT.jar
voyager-discovery-1.9.9-SNAPSHOT.jar
voyager-exp-1.9.9-SNAPSHOT.jar
voyager-index-1.9.9-SNAPSHOT.jar
voyager-launcher-1.9.9-SNAPSHOT.jar
voyager-rest-1.9.9-SNAPSHOT.jar

Patch for Version 1.9.10 (VG-6304_1.9.10_patch.zip)

voyager-api-1.9.10-SNAPSHOT.jar
voyager-common-1.9.10-SNAPSHOT.jar
voyager-discovery-1.9.10-SNAPSHOT.jar
voyager-exp-1.9.10-SNAPSHOT.jar
voyager-index-1.9.10-SNAPSHOT.jar
voyager-launcher-1.9.10-SNAPSHOT.jar
voyager-logging-1.9.10-SNAPSHOT.jar
voyager-security-1.9.10-SNAPSHOT.jar

Patch for Version 1.9.11 (VG-6304_1.9.11_patch.zip)

voyager-api-1.9.11-SNAPSHOT.jar
voyager-common-1.9.11-SNAPSHOT.jar
voyager-exp-1.9.11-SNAPSHOT.jar
voyager-index-1.9.11-SNAPSHOT.jar
voyager-launcher-1.9.11-SNAPSHOT.jar
voyager-rest-1.9.11-SNAPSHOT.jar

Patch for Version 1.9.12 (VG-6306_1.9.12_patch.zip)

voyager-api-1.9.12-SNAPSHOT.jar
voyager-common-1.9.12-SNAPSHOT.jar
voyager-exp-1.9.12-SNAPSHOT.jar

 

Web Design and Web Development by Buildable